Please note new users with 0 posts will have to have their first 2 posts approved by a Moderator or Admin. There is no point posting the same post / thread multiple times staff have a life and can't be expected to be on the forum 24/7. (December 17, 2016)



Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NAV 600 SD CARD
#1
NAV 600 SD CARD
GRATE BRITAIN AND IRELAND
2011 2012 MAPS..
FULLY WORKING ORDER......NO CASE...
WORKS ON ALL VAUXHALL CARS WITH THE NAV 600...

£29.99 POSTED....

[Image: DSC03111_zpsmhiq7d8r.jpg]
You are not allowed to view links. Register or Login to view.
Reply
#2
How did i miss this lol


Sent from my iPhone using Tapatalk
[Image: Lewis_zpswvvuzf0s.jpg]
Reply
#3
i did tell rusty i had one why how much have you just payed haha
You are not allowed to view links. Register or Login to view.
Reply
#4
£70 for the lastest one :-)


Sent from my iPhone using Tapatalk
[Image: Lewis_zpswvvuzf0s.jpg]
Reply
#5
(7:th-Mar-2016, 19:35:49)tucpal Wrote: You are not allowed to view links. Register or Login to view.i did tell rusty i had one why how much have you just payed haha

I did tell him but he wanted the newest maps.
[Image: Rusty-2_zpsuzrvgsp6.GIF]
Astra-J 2.0 CDTI S/S
Retrofitted AFL, TPMS, Navi950, BT, DAB, Rear Camera, Infinity sound system, Towbar, Flexfloor & more.
You are not allowed to view links. Register or Login to view.
I can do programming and retrofits using genuine GM MDI and Dealer software.
You are not allowed to view links. Register or Login to view.
Reply
#6
Ha that's why this one is for sale I have 2013 2014 now
You are not allowed to view links. Register or Login to view.
Reply
#7
Smile oh kool at moment its no use as I cant only listen to talk ***** sport lol.... its got a crappy christen CD in which I cant take out and now my usb has stopped working the other day so possibly a break in one the joins.
[Image: Lewis_zpswvvuzf0s.jpg]
Reply
#8
Sounds right to me
You are not allowed to view links. Register or Login to view.
Reply
#9
Could see no breaks took all tape off bud all ok. Its not even charging my phone ethier :-/ so dunno whats wrong with it now


Sent from my iPhone using Tapatalk
[Image: Lewis_zpswvvuzf0s.jpg]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)