Please note new users with 0 posts will have to have their first 2 posts approved by a Moderator or Admin. There is no point posting the same post / thread multiple times staff have a life and can't be expected to be on the forum 24/7. (December 17, 2016)



Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help diagnosing loss of power
#1
Hi. I have a 62 plate 2.0CDTI Elite manual gear box. Its all fully standard except the DriveAudio headunit.

On Tuesday I went to Manchester and back (170 mile round trip) no problem. On Wednesday I went up Bradford way, again about 170 miles odd (I don't do these types of runs every week mind).

Well on the way up Bradford, no problems. But after work I get in the car and shortly later I get a 'Service Vehicle Soon' message. I just clear it thinking its reminder to service as the car seems to drive OK.

Well anyway, I get off the M62 onto the M1 and I'm buzzing fown 3/4th lane at like 80 and all power vanishes from the accelerator. It seems if I hold foot down it will maintain current power but it will not accelerate. This goes on all the way down M1. Power goes for a minute or so but then comes back fine, 5 or 10 minutes later all power goes again for a minute. I pulled up in the services to try restarting the car after 5 minutes but I see the service soon message and it continues to lose power Intermittantly all the way down the M1 to home. But it only did it on the motorway not around town.

When this was happening all I get is service vehicle soon when I start it up. But when the power goes there is no warning, no messages, no dash lights; infact I have never seen a dash light come on in the 10 weeks I've owned the car?

Anyhow, it was from Evans Halshaw Nottingham and came with 3 months warrenty (which is obviously almost over) so I booked it in Friday morning to take Monday. But now the car has stopped flashing up the service vehicle soon message :-/ typical. Fearing they will try fob me off until warrenty ends, on Wednesday evening I brought an ODB2 reader and just dropped it on the car.

It shows no current faults, no historical fault codes, no unverified fault codes and claims nothing has been reset in 19300 miles (its now done 19600). This is with android Torque app and a second app claims the same thing (verified the apps are reading revs and boost and all the live readouts OK).

So what could be causing this and why no codes recorded?? Also any advice on how to handle Evans Halshaw would be much appreciated. I'm now worried they will just say its got no fault codes there is nothing wrong with it? But losing power at 80 in fast lane of M1 without warning I think is a pretty big deal.

Thanks!
Reply
#2
The SVS message is telling you there is a fault somewhere on the system.

The best thing to do is get it back to the dealer and get them to run a diag on it as without any information no one is going to be able to really help you.

Where are you based?
[Image: Rusty-2_zpsuzrvgsp6.GIF]
Astra-J 2.0 CDTI S/S
Retrofitted AFL, TPMS, Navi950, BT, DAB, Rear Camera, Infinity sound system, Towbar, Flexfloor & more.
You are not allowed to view links. Register or Login to view.
I can do programming and retrofits using genuine GM MDI and Dealer software.
You are not allowed to view links. Register or Login to view.
You are not allowed to view links. Register or Login to view.
Reply
#3
If you have reported the fault to Evans Halshaw they wont be able to fob you off as the fault was present at the time of warranty. Make sure you keep all correspondence, as you will need it if the problem persists after it gets 'fixed'. If you don't have any correspondence, ask for it, it is your only proof that you reported a fault, make sure the description of the issue is included in the paperwork.

As for the fault itself, it could literally be one of dozens of things, without a code or message on the dash there's nothing to go by. I would consider going to Vauxhall for a diagnostic check, if they find anything I would take those findings back to Evans Halshaw and tell them to cover the cost of the diagnostic test as theirs failed to find anything.

You must make sure you keep records of every discussion with the trader, because if they fail to fix it you will have the right to reject the car. Keep everything in writing and don't let them fob you off.
Reply
#4
So is it normal that these ODB2 readers you buy do not always report fault codes? I had one for my Vectra 150 and it always showed the problems with lambda sensors etc.

I've also just noticed now on the ECO/Top Consumers sscredn it is showing Rear Defrost constantly. Rear defrost is not supposed to be automatic right? The switch says its off and I think its preventing the Start/Stop activating..
Reply
#5
It depends on how deep within the system the fault it is. I had a Focus before the Astra and that came up with an 'Engine Systems Fault' which is a generic code not relating to anything specific. I had my own code reader which said their was no code within the system. Even the breakdown company couldn't find a code with a Snap on reader which had a Ford specific chip.

In the end I took it to Ford and their system found the code and diagnosed it as the Turbo actuator.

I dare say the 'Service Vehicle Soon' message is the same as I experienced with my Focus

Sent from my LG G4 using Tapatalk
You are not allowed to view links. Register or Login to view.
Reply
#6
Yes, it's generic.. 'service vehicle soon' covers numerous faults.
Reply
#7
they should run a full scan at the dealers and hopefully find the fault
i had this happen a few months back and the car needed a regain
the car just needs reading with the correct software not all readers can do this
You are not allowed to view links. Register or Login to view.
Reply
#8
Ok. Thought the reader should pick it up. See what they say tomorrow then.

The fault had stopped popping up Friday evening / Saturday but I took it 15 mins down the M1 again today and eventually the 'service vehicle soon' message came back. It was OK on the way back but after I got off the M1 the message came on and it started limping again at like 30mph.

I hope it doesn't turn into a drama with them. I'm hoping I can rule out the common regen problems as this is happening so far after Motorway runs (when it should be able to regen) and I've never had the regen light appear. If they start teling me I'm not driving it right and it's my fault I'll be upset.
Reply
#9
Got the car back yesterday. In fairness to them there was no hassle at all really. They did keep it overnight whilst they waited for a part but didn't cost anything. All I was really able to get out of them was a temperature sensor was faulty and it can cause the ecu to think it's over heating and shut down the engine? Not sure where this sensor is, just the lady on one of the service desks in the showroom.

Also said did an ecu update..
Reply
#10
Glad you've got it sorted. I was on the M1 on Sunday heading North.
[Image: Rusty-2_zpsuzrvgsp6.GIF]
Astra-J 2.0 CDTI S/S
Retrofitted AFL, TPMS, Navi950, BT, DAB, Rear Camera, Infinity sound system, Towbar, Flexfloor & more.
You are not allowed to view links. Register or Login to view.
I can do programming and retrofits using genuine GM MDI and Dealer software.
You are not allowed to view links. Register or Login to view.
You are not allowed to view links. Register or Login to view.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Power, performance and looks RVernon 1 0 16:th-Jul-2019, 13:45:07
Last Post: Rusty2009
  Lacking Power - What can I check everson38 3 0 10:th-Jul-2019, 10:44:50
Last Post: Big Dave2
Information No power Taylor89 7 0 4:th-Jun-2019, 20:27:03
Last Post: Jpbroad1970
  wires power amplifier alexy357 8 0 3:rd-Mar-2019, 17:05:22
Last Post: alexy357
  1.6 cdti power loss ihastings 25 0 19:th-Oct-2018, 07:37:42
Last Post: Rusty2009
  Slow coolant loss Dennis S 21 242 8:th-Jan-2018, 11:13:20
Last Post: Dennis S
  2.0cdti ECU update for DPF causing poor fuel & loss of performace Rusty2009 17 1,653 23:rd-May-2017, 07:00:23
Last Post: Rusty2009
  Memory Loss Negative Terminal spybot 2 617 27:th-Jun-2016, 01:15:33
Last Post: bhalay207
  GAIN MORE POWER ASTRA J 2.0 CDTI ECOFLEX ELITE 165BHP Bturbo123 44 9,809 3:rd-Jun-2016, 14:14:02
Last Post: tucpal
  USB Port Power Boost sheppy1 6 1,669 10:th-May-2015, 23:12:40
Last Post: tucpal

Forum Jump:


Users browsing this thread: 1 Guest(s)