Please note new users with 0 posts will have to have their first 2 posts approved by a Moderator or Admin. There is no point posting the same post / thread multiple times staff have a life and can't be expected to be on the forum 24/7. (December 17, 2016)



Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Auto gear box
#1
Hi all my daughter has a 2010 astra j 1.6 auto the problem is it wont change out of first gear , it will go into park but when you put it in drive it stays in 1st and does not change up, in reverse its ok, the engine warning light has come on and when we had the aa out 2 codes came up saying input speed sensor malfunction -p0716 the other code said input speed sensor no signal p0717, has anyone had the same problem or no of it happining to anyone, your hepl would be appreciated.
Reply
#2
Sound's like it could be the sensor at fault or a broken wire.

Would be best getting a good auto spark out to look at it.
[Image: Rusty-2_zpsuzrvgsp6.GIF]
Astra-J 2.0 CDTI S/S
Retrofitted AFL, TPMS, Navi950, BT, DAB, Rear Camera, Infinity sound system, Towbar, Flexfloor & more.
You are not allowed to view links. Register or Login to view.
I can do programming and retrofits using genuine GM MDI and Dealer software.
You are not allowed to view links. Register or Login to view.
Reply
#3
it's worth checking the wiring to the sensor for damage or breaks
otherwise it needs some further diagnostics
this might help (or not) depending on gearbox model

You are not allowed to view links. Register or Login to view.
retrofitted = DAB+, GM dog guard
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)